Saturday, April 07, 2007

After a fresh install...

on an e1405 of ubuntu:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install network-manager-gnome 915resolution

reboot

apt-get install build-essential quanta kdevelop anjuta screem bluefish vlc emacs-snapshot-gtk gaim gaim-guifications gaim-extendedprefs gaim-hotkeys gaim-encryption mozilla-thunderbird deskbar-applet openssh-client openssh-server subversion k3b screen inkscape pan gqview unrar par2 nmap wireshark bitchx gstreamer0.8-plugins libgtk2.0-dev python-mode

manually install automatix to get more apps.

manually install beryl.

if dual_booting:
ntfs-3g

References used:
Dell e1405 WXGA+, X wouldn't start
Essentials, 2006 edition

Note: Transmission source 0.6.1 has a bug where it identifies gtk 2.10 as old, downloading source from svn and compiling that fixes this problem.